Исполнитель Нода преобразует число на экране. У исполнителя есть три команды, которым присвоены номера:

1. Прибавить 1
2. Прибавить 3
3. Прибавить 7

Программа для исполнителя – это последовательность команд. Сколько существует программ, для которых при 
исходном числе 13 результатом является число 31? Все пары чисел траектории вычислений должны быть 
взаимно простыми (под парой подразумевается два подряд идущих числа).
Например, из числа 24 командой 2 (+3) нельзя перейти в число 27, потому как оба эти числа 
делятся на 3. А из числа 25 можно перейти в 28., т.к. для этих чисел нет общих простых делителей,
 т.е. числа взаимно простые.

def NOD(x,y):
    if y==0:
        return x
    else:
        return NOD(y,x%y)
        
def f(old,s,f1):
    if NOD(old,s)!=1:
        return 0

    if s>f1:
        return 0
    if s==f1:
        return 1
    h=[]
    h.append(f(s,s+1,f1))
    h.append(f(s,s+3,f1))
    h.append(f(s,s+7,f1))
    
    return sum(h)
print(f(2,13,31))# 2 - это любое число не кратное 13

